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1. SpectreRF Overview
• SpectreRF is an optional feature added to Spectre ,and is

represented by 6 analyses:
1. PSS: Periodic Steady State Analysis
2. PAC: Periodic AC Analysis
3. PXF: Periodic Transfer Function Analysis
4. PNOISE: Periodic Noise Analysis

Tdnoise: Time Domain Noise
QPNOISE: Quasi-Periodic Noise (not discuss here)

5. PDISTO: Periodic Distortion Analysis
QPSS: Quasi-Periodic Steady State (not discuss here)

6. Envelope Analysis (not discuss here)

PAC, PXF, and PNOISE are similar in concept to AC, XF, and Noise.
However, they are applied to periodically-driven circuits such as mixers and
oscillators.
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SpectreRF in a Design Flow

Schematic

Models The netlists include all
components along with an

analysis selection, simulation
controls and statements to save,

plot nodes or currents.

Use Direct plot or the
Calculator plot capabilities.

Spectre RF Control

Design

Netlist

Analog Artist Environment

Analog Artist Plot Results

SPECTRE Engine
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SpectreRF Tool Flow

PSS is a large-signal analysis
and determines the period of
the small-signal analyses.
PSS requires that multiple
periodic stimuli be
coperiodic.

PDISTO is also a large-
signal analysis, and need not
to be run after a PSS
analysis. PDISTO does not
require multiple periodic
stimuli to be coperiodic.

SpectreRF

Spectre Engine
PSS Analysis

PSS setup

PSS ResultsPDISTO Results

PDISTO Setup

Spectre Engine
PDISTO Analysis

Spectre Engine
-PAC Analysis
-PXF Analysis
-PNOISE Analysis

Report Results

Stimuli is coperiodic
Yes

No
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SpectreRF Features

• Compute a steady-state solution efficiently and directly

• Handles very large circuits (~ 10,000 transistors)

• Displays results in both time and frequency domains

• Use Discrete Fourier Transform (DFT) for better accuracy

• Displays standard RF measurements, such as s-parameter in Smith

chart, NF, IP3, and 1dB compression point in the Analog Artist design

environment.

• Performs oscillator analysis.
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2. S-Parameter Analysis

• Linear Simulation:
– Entirely in the frequency domain
– A basic RF feature of the Spectre simulator

• Ports:
– Specify the port number on the psin ( or port); psin (or port)

can act as a source port or a load.
– Required properties for linear analysis: Resistance & Port

number

• Noise Analysis:
– Use Nfmin and NF for 2-port circuits ONLY.
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Plotting S-Parameter Simulation Results
SP, ZP, YP, HP   s-, z-, y-, and h-parameters
GD                       group delay
VSWR                 Voltage Standing Wave Ratio
NFmin                 minimum noise figure
Gmin                   reflection coefficient associated with Nfmin(also known as Γmin, Γopt, or Γon)
Rn                        noise sensitivity parameter
rn                         normalized equiv. Noise resistance
NF                        noise figure
Kf & B1f              stability terms
GT                        transducer gain
GA                       available gain, assuming conjugate matched output
GP                        power gain, assuming conjugate matched input
Gmax                  maximum available power gain
Gmsg                  maximum stable power gain
Gumx                  maximum unilateral power gain
ZM                       impedance at port m
NC                        noise circles
GAC                     available gain circles
GPC                      power gain circles
LSB                      load stability circles
SSB                      source stability circles
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Lab1 : S-parameter Analysis
• Create a new library

and a new schematic
view.

• Use library “analogLib”
& “tsmc25rf” to draw
the scheme.

• After drawing, push
Design → Check and
Save; then push Tools
→ Analog
Environment, and the
window “Affirma
Analog Circuit Design
Environment” will
appear.

create instance from
library “tsmc25rf”
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Setup Design Environment(1)
• Push Setup → Model

Libraries then the window
“Model Library Setup”
appears. Setup the model
library as shown right. Then
click OK.

• Push Setup →
Simulator/Directory/Host
to designate the project
directory. The default project
directory is “ ~/simulation “ .

Use “Browse” to access to the model files
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Setup Design Environment(2)

• You can use either an
absolute model path or a
relative model path

• IF you use the absolute
approach, the setup is as
shown right-upper.

• To use a relative path ,push
“Setup → Simulation
Files”,than Setup →
Model Libraries .The
setup is as shown right.
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Setup Design Environment(3)
• Push Analyses → Choose then the window

“Choosing Analyses” appears. Key in the
values as right and push ok, then some
information will appear in the “Analyses”
domain of the window “Affirma Analog
Circuit Design Environment”.

• Push Simulation → Netlist and Run to run
the simulation. The Netlist will be saved under
a directory called ~/simulation.

Netlist and Run

Push Select button then
to select the port on the

schematic window



CIC

2-7

See the Results
• Use the Direct Plot tool to look the results.
• In the “S-parameter Results” window choose some

parameters to see their results.



CIC

2-8

Some Results
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Save the results to *.s2p
• Edit the S-Parameter Options,

and enter the path to the output
S-parameter file in the file
field of the OUTPUT
PARAMETERS section and
OK the S-Parameter Options
form.

• And Simulate again. Check if
the file is created in the
appointed directory.
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S2P File
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Simulation State
• Push Session → Save State to save simulation states under a directory

called ~/.artist_states. Designate a new directory  with the Session →
Options command in the simulation window.

• Push Session → Save State to load saved states for a design.
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Read the S2P file(1)
• Create a new schematic

view.

• Use library “analogLib”
(n2port cell) to draw the
scheme.

• Simulate if the results
are the same as before.
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3. Lab2: Swept DC Analysis
• Create a new schematic view and use library

“analogLib” & “tsmc25rf” to draw the scheme.

• . After “Check and Save” ; then call the window
“Affirma Analog Circuit Design Environment” .

• Setup up the Model Libraries.

• Push Variables → Copy From Cellview, and the
defined variables appear in the “Design
Variables” section. Double click on

the variable name or push Variables → Edit, the window “Editing Design Variables”
appears. Key in the appropriate value for the variables.



CIC

3-2

Set up the Design Environment(1)
• Call the window “Choosing Analyses” and  key in the values as right and push ok.

• To plot power or current at the end of the simulation,
you must explicitly save the currents necessary for
the calculation before the simulation. The voltages at
each node are saved by default.

• Select Outputs → To Be
Saved → Select On
Schematic. In the
schematic, select the
NMOS. The terminals are
circled in the schematic
window after you select
them. Press Esc to end the
selections.
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Set up the Design Environment(2)
• In the window “Design Environment” select Tools → Parametric Analysis… ;

the window “Parametric Analysis” appears, then key in the values as below .

• In the window “Parametric
Analysis” select Analysis
→ Start to start the
simulation.
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The Results
• Select Results → Direct Plot → DC and select the terminal “Drain” of the nmos in

the schematic window; then push ESC, and the results will be showed.
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4. Periodic Steady State Analysis

• Directly computes the periodic steady-state response of a circuit in
the time domain.

• Iterative Shooting Newton method is employed.

• Calculate frequency translations using the saved matrices at every
time point.

• The fundamental frequency of the circuit or system is determined,
based on integer multiples of all source frequencies.

• The circuit is evaluated for one period of the common frequency,
and the period is adjusted until all node voltages and all branch
currents fall within a specified tolerance.
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Shooting Newton Method
• PSS operates by efficiently

finding an initial condition that
results in steady state.

• The first iteration is transient
simulation from t=0 to t=1/PSSfund
by default. The tstab parameter
can be adjusted to facilitate
convergence.

• The second iteration is PSS
analysis between t=tstab to
t=(tsatb+1/PSSfund) and compares
all voltage and currents at the start
and end of the shooting interval.
Set the value of tstab to keep
“start-up behavior” away.

The starting point is adjusted
by the shooting method to

result in periodic steady state.

The signal starts at a
point vi doesn't

result in periodicity.

vi

vf
∆v

tstab

t=0s t=1/PSSfundt=2/PSSfund

Transient Analysis
PSS Analysis

All node voltages
and Admittance

Matrices are saved

Shooting
Interval
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Shooting Newton Method(continued)

fundPSS
1τ=

fundPSS
1τ=

Transient Analysis PSS Analysis
RF 2.4GHz

LO 2.3GHz

IF 100MHz

PSSfund=100MHz

• Shooting method takes the last few point data at the
end of the shooting interval to adjust the slopes of the
waveform at the beginning of the next iteration.

• If 20 iterations do not yield a solution, this might
indicate the circuit won’t converge to a PSS solution.
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PSS Analysis Assumptions

• 1st Assumption : Periodicity
– All stimuli are periodic and coperiodic with the PSSfund ; All

responses are periodic.
– PSSfund can be set to includes the subharmonics.
– If periodicity assumptions fail, PSS analysis will not converge.

• 2nd Assumption : Linearity
– A near-linear relationship need to exist between initial and final

points of the shooting interval.
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The PSS Fundamental
150 MHz

RF Input

900 MHz

Local
Osc.

Local
Osc.

1050 MHz 160 MHz

10 MHz

IF1 IF2
Mixer BPF Mixer BPF Output

PSSfund = 10 MHz
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PSS Operation

Yes

Yes

No

No

Start PSS
Initial Transient

(1 period or tstab)

1 Period of
PSS AnalysisPeriodicity Meet?

Final State
=

Initial State

Exit

Refine
Initial
Guess
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Simulator Accuracy Suggestions
• Do not set “conservative”. This will dramatically extend the simulation time.
•
• The suggested settings are recommended for IP3 Analysis, Noise Analysis,

or wherever high accuracy is needed.
• Choose the gear2only integration method. The default trap integration

gear2onlytrapMethod

1e-131e-12iabstol

3e-81e-6vabstol

1e-51e-3reltol

Suggested SettingsDefaultsParameter

10.00.00001<0.1/maxacfreqgear2onlyalllocalx0.1conservative

3.50.001<0.2/maxacfreqtraponlysigglobalx1.0moderate

3.50.1<0.4/maxacfreqgear2allglobalx10.0liberal

lteratiosteady-ratiomaxstepmethodrelrefreltolerrpreset

osteadyrati*lteratio*reltolΔ IandΔ V <

method yields
underdamping and
gearOne yields too
much overdamping.
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Normalized Convergence ratio

• When the Conv norm is 1(unity) or less, the simulation
meets the matching criterion.

• The PSS messages also display the number of PSS
iterations, the number of accepted timesteps, and the total
time required for PSS analysis.

Conv norm =
Measured ∆V between start and end of shooting interval

reltol*lteratio*steadyratio
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Lab3 : PSS and swept PSS Analysis
Create a new
schematic view and
use library
“analogLib” &
“tsmc25rf” to draw
the scheme.

Port1:
Frequency name: F1
Resistance: 50
Source type: sine
Amplitude(dBm): -40
Frequency: frf

Port2:
Frequency name: F2
Resistance: 50
Source type: sine
Amplitude(dBm): 8
Frequency: flo

Pif
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Setup up the PSS Simulation(1)
• Model library setup.

• Call the window “Affirma Analog Circuit Design Environment”; key in
appropriate value for the variables in the “Design Variables” section.

• Analyses →
Choose. In the
window “Choosing
Analyses”, select
pss.



CIC

4-11

Setup up the PSS
Simulation(2)

• The Signal field is ONLY applicable to the pdisto
analysis.

• Beat Frequency represents the PSS Fundamental
(PSSfund) frequency. This fundamental is the highest
frequency that evenly divides into all frequencies in
the circuit. You may key in an appropriate value or
push Auto Calculate button to get an auto-
responded value.

• Set the value for number of harmonics. The
number of harmonics won’t affect the simulation
accuracy or time.

• Make sure the Enabled field is on.
• Click the Options button and set the integration

method to gear2only.
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Setup up the PSS Simulation(3)
• In the Analog Artist Simulation window,

select Simulation → Options →
Analog. Set the Tolerance Options as
recommended. If it is hard to converge
set the Tolerance Options looser. 

• Finally, Select Simulation → Netlst
and Run to start the
simulation. Note if the
Conv norm is less
than 1 or if the PSS
simulation has a
convergent result.
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Display the Conversion Power Gain-
method 1

• In the Analog Artist Simulation Window, select Results
→ Direct Plot → PSS. Note the prompts on the bottom
of the schematic and PSS Results windows.

• The PSS Results window MUST be on the screen when
probing the nodes in the schematic. Don’t push OK. 

• In the PSS Results form, use the cursor to select the Pif
net and Prf nets on the schematic. Press Esc to end this
command.

• Click the Switch Axis Mode icon on the Waveform
Window or select Axes → To Strip.
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Display the Conversion Power Gain-
method 1(continued)

• Click the Crosshair Marker A
icon and place the marker on the
2.4GHz harmonic of Prf.

• Click the Crosshair Marker B
icon and place the marker on the
100MHz harmonic of Pif.

• Prf:
Magnitude: 4.0085m
Power: ≅ -38 dBm

• Pif:
Magnitude: 4.08038m
Power: ≅ -37.8 dBm

• Conversion Power Gain               
≅ 0.2dB + 3 dB = 3.2 dB
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Display the Conversion Power Gain-method 2

• Select Output → Save All … and the window “Save Options” appears. Set the
buttons as below window in order to get the AC power!

• Select Outputs → To Be Saved → Select On Schematic. In the schematic, select
the PORT1 and RL1. The terminals are circled in the schematic window after you
select them. Press Esc to end the selections.

• Double click on the name in the Outputs
section or select Outputs → Setup. Set
the outputs Will Be Plotted and Saved.
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Display the Conversion Power Gain-
method 2(Continued)

• Push Netlist and Run icon to run this simulation.
• Select Results → Direct Plot → PSS. Set the function and

modifier as right; Select instance terminal(PORT1 & RL1) in
the schematic window. Press Esc to end the selections.

• Compare the results to those of method 1.
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1 dB Compression Point Simulation
• Change the Amplitude(dBm) of PORT1 to a variable prf; Designate a value to prf in the

Design Variables section.
• In the Choosing Analyses window, turn on the Sweep button as shown here. Type in prf for the

Design Variable Name, or click the Select Design Variable button, and highlight prf from a
list , then click OK.

• Remember to check in the INTEGRATION METHOD PARAMETERS the method is
gear2only.

• Select Netlist and Run button.
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P1 dB Simulation Results
• Use Direct Plot function to see the results. Set up PSS

Results form as shown here. Then select the Pif net in
the schematic. With the cursor still in the schematic
window, press ESC key to end the Direct Plot
command.
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Simulating IP3
• PSS by itself is seldom used for IP3 simulation, because the separation between the

2-tone frequency is typically only a few Khz, and leads to a very long simulation time.
• Edit PORT1 properties as right. So The Fundamental (Beat) Frequency is

now 25MHz.
• Set up Choosing Analysis form appears as shown below and push OK
• Run the  simulation
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IP3 Results
• Use Direct Plot function to see the results. Set up PSS

Results form as shown here. Then select the Pif net in the
schematic. Press ESC key to end the Direct Plot command.

3rd order intermodulation product will occur at
(2 × 2.4GHz – 2.425GHz) – 2.3GHz = 75 MHz
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5. PAC Analysis
• PAC is a small-signal analysis like AC analysis, except the

circuit is first linearized around a periodically varying operating
point as opposed to a simple DC operating point. Linearizing
around a periodically time-varying operating point allows
analyzing transfer-functions that include frequency translation.

• When a small sinusoid is applied to a linear circuit that is
periodically time-varying, the circuit responds with harmonics.

• PAC computes a series of transfer functions, one for each
frequency. These transfer functions are unique because the input
and output frequencies are offset by the harmonics of the LO.
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PAC Analysis Overview
• PAC computes the transfer function

from one input to many outputs.
PAC is similar in concept to normal
small-signal AC analysis, but it also
calculates frequency conversion
effects.

• By setting the maxsideband value to
Kmax, PAC generates all 2Kmax +1
sidebands from – Kmax to +Kmax.

• The small-signal frequency in a PAC
analysis can be arbitrarily close or
even equal to the LO frequency.

Input

LO

Output

fundinout PSSKiff ×+=
where fin represents the input frequency,
and Ki are the PAC sidebands

LO

State

Input

Output

0 1 2 3 4PSSfund Harmonic no.

PAC Sideband no.-3 -2 -1 0 1 2 3

f

f

f

f
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Fundamental PAC Assumptions

• The PAC small signal analysis assumes that the circuit responds in a small
signal fashion to the sinusoidal stimulus. This is accomplished by keeping the
magnitude of the PAC signal at least 10 dB below the 1 dB GCP.

• The harmonics of the small signal PAC tone are not computed, although
small signals can be used to measure distortion caused by the large signals
present in the PSS analysis.

• For the transfer function to be accurate, a large number of time steps, during
the PSS analysis, are needed at the small signal frequency. If the analysis
frequency of the small frequency analysis is too high, the accuracy degrades.
The maxaxfreq parameter of the PSS analysis can be used to specify the
highest frequency that SpecteRF uses in subsequent small signal analyses.
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PAC Analysis Summary
• Specify the following information when running a PAC analysis:

Plot results relative to output or absolute
value of output frequency. Input is of little
value and is not used.

Results format

Sidebands or Array of IndicesOutput frequencies of interest
Sweep, array or single pointInput sweep frequency
Set type to dc and specify PAC magnitudeInput port

The number of harmonics should be no less
than the PAC harmonics. *PSS fundamental

* When setting Output harmonics less than the PAC harmonics, be sure to set
the maxacfreq parameter to assure that the simulator takes sufficient time
points to accurately characterize the output waveform in the PSS analysis.
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Lab4 : PAC Analysis
• Use the same schematic as Lab3.
• Modify the parameter values of PORT1 as below table.

Note :  When the source type is set to dc, this signal  will not be checked for
coperiodicity with the other signals; this source will be treated as a small signal.
When the source is set to sine, it will be considered “large signal”.

50Resistance

(blank)Frequency2
(blank)Amplitude2 (dBm)
prfAmplitude (dBm)
1PAC magnitude
frfFrequency
dcSource type

ValueParameter
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Setting Up the PAC Simulation
• Call the window “Choosing Analyses”; In the pss form,

fill in the form as left; then click Apply.
Note the number of harmonics is set to 0, because the PSS simulation
is only run to calculate the large-signal, steady state solution.

• Click on pac in the Choosing
Analyses form, and setup the form
as left; then click OK .
The Frequency Sweep Range sets the
sweep range on the psin(port) component
at the input port which has a PAC
magnitude parameter value specified.
The value for Maximum sideband is
relative to the Fundamental frequency.
Since the LO frequency and PSSfund are
equal, you get the results of mixing the RF
with the 0 through 3rd harmonic of the LO.

• Select Netlist and Run.
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Plotting the Conversion Gain

• Note how much faster this
simulation runs than the previous
method used to calculate CG.

• Use Direct Plot function to see
the results.

• In the schematic window, select
the Pif node, and the result are
plotted as next page:
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Periodic Steady State Response
• To measure the CG,

move the marker to
the 100MHz
position in the
waveform window
and read the gain.

-1
-2

0

1

-3

2 3

Note if the input and
output port are both
matched to 50ohm,
we get conversion
power gain;
otherwise we get
conversion voltage
gain.
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Running a Swept Small-Signal IP3 Simulation
• Modify the parameter values of PORT1 as right

table; then check and save!
• Select pss in the Choosing Analyses form, and

setup the form as below : Note now the
Fundamental Frequency is 100 MHz

• Set the Number of harmonics to 50 and you
have the harmonics available to view; it won’t

prfPAC magnitude (dBm)

50Resistance

(blank)Frequency2
(blank)Amplitude2 (dBm)
prfAmplitude (dBm)

(blank)PAC magnitude
frfFrequency
sineSource type

ValueParameter

affect the
simulation time.

• Click Apply!
The Choosing
Analyses form is
still active on the
screen.
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Setup up the PAC Simulation
• In the Choosing Analyses form,

select pac; then set up the form as
right:

• This simulation applies a 2.425GHz
tone in the PAC analysis to compare
the results by the swept PSS. This
PAC test tone is typically separated
according to “channel spacing”.

• Click OK.

• Select Netlist and Run.
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IP3 Results
LO: 2.3 G           RF: 2.4 G & 2.425G

1st order harmonics: 100M & 125M         3rd order harmonics: 75M & 150M

• The only 1st and 3rd order pair available from this analysis
(due to the 100MHz PSSfund) is 125M and 75M.

• Use Direct Plot function; select the Pif net in the
schematic window.

• Compare the IP3 values using 2 different method!
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6. PXF Analysis
• The periodic transfer function (PXF) analysis directly

computes such useful quantities as conversion efficiency(the
transfer function from input to output at a preferred frequency),
image and sideband rejection, and power supply rejection.

• The primary use of PXF analysis is to measure various
conversion gains. This is very valuable when looking at
different spurs on the input of a receiver.

• PXF can be a better choice for calculating CG than PAC,
because PXF will provide information on all of the frequencies
on the RF port that are converted to the IF band.

• When simulating oscillators, PXF can determine the tstab
value.
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PXF Analysis Overview
• The PXF analysis computes the

energy contributions from all source
harmonic frequencies to a signal or
swept output frequency. In this way,
a single output response is the
combination of all possible
frequency components in the design.

• Set the maxsideband, or the
sidebands parameters, to select the
periodic small-signal input
frequencies of interest, while
sweeping the selected output
frequency.

Input

LO

Output

fundout
k
in PSSkff ×+=

where fout represents the output signal
frequency; k is the PXF sidebands number

LO

State

Output

Input

0 1 2 3 4PSSfund Harmonic no.

PXF Sideband no. -2 -1 0 1 2 3 4

f

f

f

f
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Fundamental PXF Assumptions
• The PXF small signal analysis assumes that the circuit

responds in a small signal fashion to sinusoidal stimulus.
SpectreRF is not capable of computing the distortion caused
by the small signals, although small signals can be used to
measure distortion caused by the large signals present in the
PSS analysis.

• To increase accuracy, choose a large number of time steps
during PSS analysis. If the analysis frequency of the small
signal analysis is too high, the accuracy of the results degrade.
The maxacfreq parameter of the PSS analysis specifies the
highest frequency uses in subsequent small signal analyses.
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PXF Analysis Summary
• Specify the information in this table when running a PXF analysis.

(To measure current, put a 0v battery in series
with the branch. )

Voltage source (i)

Plot results relative to input or absolute input
value of input frequency. Output is of little
value and is usually not used.

Results format

SidebandsInput frequencies of interest
Sweep, array or single pointOutput sweep frequency

Specify in formOutput net (v) or

The number of harmonics should be no less
than the PXF harmonics. *PSS fundamental

* When setting Output harmonics to 0, be sure to set the maxacfreq parameter
to assure that the simulator takes sufficient time points to accurately
characterize the output waveform in the PSS analysis.
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Lab5 : PXF Analysis
• Because PXF is a small signal analysis, only one large

signal tone, the LO, is required. Set the PORT1 as
follows:

50Resistance

(blank)Frequency2
(blank)Amplitude2 (dBm)
prfAmplitude (dBm)
(blank)PAC magnitude (dBm)
frfFrequency
dcSource type

ValueParameter

Pif Pif-
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Setting Up the PXF Simulation(1)
• In the Simulation window, select Analyses →

Choose; turn off the pac analysis. Then select
the pss analysis, and set up the form as right:

• Note the number of harmonics is set to 0,
because the PSS simulation is only run to
calculate the large-signal, steady state
solution. Therefore set a value for maxacfreq
in the PSS Options form. Set maxacfreq to 4
GHz.

• Click Apply in the Choosing Analyses form.
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Setting Up the PXF Simulation(2)
• Click on pxf in the Choosing Analyses form, and setup

the form as left; then click OK .
• The Frequency Sweep Range is specified from 1MHz to

300 MHz. The PXF analysis will calculate all inputs that
produce this range of frequencies at the Pif port.

• To set the Positive Output Node, click the Select button,
and select the Pif node in the schematic.

• Click the
Netlist and
Run.
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Plotting the RF to IF Conversion Gain
• Use Direct Plot function to see the results. In the PSS Results form, select pxf

button. Follow the prompts at the bottom of the form, and select the port
component (PORT1) in the schematic

0

-1 1

-2
2 -3

3
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Power Supply Rejection
• Double click on the pxf analysis in

the window “Design
Environment”, and the Choosing
Analyses form appears. Change
the Negative Output Node to Pif-
(/net016) in the pxf form, then
click ok.

• Run the simulation.
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Plotting the Power Supply Rejection

0

-1 1

-2 2

-3 3

• Use Direct Plot function to see the results. In the PSS Results form, select
pxf button. Follow the prompts at the bottom of the form, and select the DC
supply (vdc=2.5v) in the schematic
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7. PNOISE Analysis
• PNOISE analysis, unlike conventional noise analysis,

computes frequency convention effects, noise folding, aliasing.
• For noise sources that are bias dependent, such as shot noise

sources, the time-varying operating point acts to modulate the
noise sources. The transfer function from the noise source to
the output is also periodically time-varying, and so acts to
modulate the contribution of the noise source to the output.
The effect of a periodically time-varying bias point on the
noise generated by the various components in the circuit is
also included.

• Include the effects of thermal noise, shot noise, and flicker
noise.
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PNOISE Analysis Overview(1)
• The final result of the analysis

is the sum of the noise
contributions from both the up-
converted and down-converted
output frequency specified.

• By setting the maxsideband
value to Kmax, all 2×Kmax+1
sidebands from – Kmax to +Kmax
are generated. The number of
requested sidebands has a small
effect on the simulation time.

Input

LO

Output

fundioutcenoise_sour PSSKff ×+=
where fout represents the output signal
frequency; Ki is the PNOISE sidebands no.

PSSfund Harmonic no.

PNOISE Sideband no.

0 1 2 3 4

-2 -1 0 1 2 3 4

LO

State

Output

Input
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PNOISE Analysis Overview(2)

• When the reference sideband has any value other 0,
Single Sideband (SSB) NF is calculated. To
determine the reference sideband, run a PXF analysis.

• The Noise Summary Table displays the following
data:
– Noise contribution (value and %) for each component in

the circuit
– Total output noise
– Total input referred noise
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Fundamental PNOISE Assumptions

• The small signal analyses compute transfer function by using
time-domain techniques. The time steps used in these time-
domain computations are the same as those in PSS analysis. For
accuracy, the PSS analysis needs to have many data points at the
highest frequency that you want to analyze in the noise analysis.

• More sidebands yield greater accuracy, but they take longer to
simulate and use more disk space. If the analysis frequency of
the small signal analysis is too high, the Spectre simulator
warns. Use the maxacfreq parameter of the PSS analysis to
specify the highest frequency for SpectreRF to use in
subsequent small signal analyses.
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PNOISE Analysis Summary
• Specify the information in this table when running a PNOISE

analysis.

Noise figure and Input referred noiseReference Sideband
Port, voltage or current sourcesInput Sources
SidebandsInput frequency contributors
Sweep, array or single pointOutput sweep frequency

Specify in formOutput net (v) or Voltage source (i)

The number of harmonics will likely be
no less than the PNOISE harmonics.PSS fundamental
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Lab6 : Noise Figure

• Modify the parameter values of PORT1 as follows:

• In the Simulation window, select Analyses → Choose; turn
off the pxf analysis.

50Resistance

(blank)Frequency2
(blank)Amplitude2 (dBm)
(blank)Amplitude (dBm)
(blank)PAC magnitude (dBm)

frfFrequency
dcSource type

ValueParameter
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Setting Up the PNOISE Simulation(1)

• Then select the pss analysis, and set up the form as
right:

• Set a value for maxacfreq in the PSS Options
form. Set maxacfreq to 20GHz. Remember to set
the integration method to gear2only.

• Click Apply in the Choosing Analyses form.
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Setting Up the PNOISE Simulation(2)
• Click on pnoise in the Choosing analyses form, and

set up the form as right:

• A Maximum sideband of 8 implies PNOISE will
calculate the noise out to 8 harmonics of the PSSfund, or
18.4 GHz.

• To set the Positive/Negative Output Node, click the
Select button, and select the Pif/Pif- node in the
schematic window.

• Click the Select button and select PORT1 component
in the schematic to set the Input Port Source.

• To obtain the Reference Side-Band, run PXF analysis.

• Finally, push OK; then Netlist and Run.
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Plotting the NF
• Use Direct Plot function to see the results. In the PSS

Results form, select pnoise button. Click Plot button,
and the waveform window displays the results.



CIC

7-10

Printing the Noise summary Report

• It is valuable to know the main contributions of noise in a
system. This information is readily available from a PNOISE
simulation.

• In the Analog Artist
Simulation window, select
Results → Print → PSS
Noise Summary. The
Noise Summary form
appears. Fill the form as
shown here.
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The Noise Summary Table

• Click OK in the Noise Summary form, and the Noise
Summary Table displays.

• Note what are the main contributions of noise.
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Time Domain Noise

• The noise in RF circuits is generated by sources that
can typically be modeled as periodically time-
varying. Noise that is periodically time-varying is
also called cyclostationary noise.

• Might or might mot be independent (correlated).

• Becomes intricate with nonlinear elements, with
memory, or driven by time-varying signals.
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Time Domain Noise Overview
There have been 3 new noise type parameters added to
PNOISE analysis:

1. sources:
– Compute time-averaged total noise power at a signal output, in the

frequency domain.

2. timedomain:
– Calculates the time-varying instantaneous noise power in a circuit

with periodically driven components
– Setting the NOISE Skip Count=N parameter will only compute the

noise at every Nth timepoint in the PSS waveform.

3. correlations:
– Calculate correlations in noise at different ports of a multiport circuit
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Lab7: Calculating Time-Varing
Instantaneous Noise Power

• Create a new schematic
view.

• Use library “analogLib” &
“tsmc25rf” to draw the
scheme.

• After drawing, Check and
Save!
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Setting Up the PNOISE
Simulation(1)

• Open the Design Environment
window and set up a PSS analysis as
shown right:

• Click the Options button and set the
method to gear2only.

• Click Apply.
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Setting Up the
PNOISE Simulation(2)

• On the PNOISE analysis form,
select timedomain in the NOISE
Type field.

• Set up a PNOISE analysis as
shown right:

Note: If the Noise Skip Count is set to an
integer p, then noise will be calculated at
every p+1 points. When the Noise Skip
Count is 0 (default), it calculates the
noise at every timepoint in the final PSS
solution.
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Plotting Time Domain Results

• Click the Netlist and Run icon to start the simulation.
• Use Direct Plot function to view the time domain plot of

v(out)
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Plotting Time Domain
Noise Results

• In the PSS Results form, click tdnoise
and set up the form as shown right:

• Click Plot button.

At about 4.1ns when
waveform transition
happens, the inverter is
the most noisy.
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Plotting Time Domain Noise Results
on Spectrum(1)

• To display the spectrum
of the noise results, set
up the PSS Results form
as show right:

• Click Plot. See the result
in the next page.
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Plotting Time Domain Noise Results
on Spectrum(2)
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8. Periodic Distortion Analysis
• PDISTO is an analysis that invokes a series of PSS like analyses over all

input frequencies, their harmonics, and the intermodulations of the
frequencies and harmonics.

• Similar to PAC, the PDISTO analysis calculates the responses of circuits that
exhibits frequency translations. However, instead of simulating small signal
behavior, PDISTO models the response from moderately large input signals.

• Use PDISTO to calculate intermodulation distortion from two or more large
input signals. PDISTO treats one particular input signal as the large signal,
and the others as moderate signals.

• PDISTO allows arbitrary signal signal inputs, including sums of sinusoids
that might not be periodic, it as a quasi-periodic extension of PSS. PDISTO
can be thought of as an extension of PAC that allows signal signal inputs,
capable of producing third-order products, to be used.
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PNOISE Analysis Overview
• Internal to the simulator, one input is treated as the large

signal, which causes the most nonlinearity or the largest
response in the circuit.

• Other signals are treated as moderate and do not need to
be harmonically related to the large signal or integer
multiples of each other.

• The moderate signals can be large enough to create
distortion (near P-1dB point)

• The ability to sweep PDISTO provides a way to perform
intermodulation distortion calculations with multiple input
signals, considered as large signals.
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PDISTO   v.s.   PAC
• PDISTO analysis yields more information than PSS followed

by a PAC analysis, when modeling intermodulation distortion.

900 905

Input Spectrum RF Amplifier

5 900 905

895

1800

1805

5 900 905

895

1800

1805895
10

1810

PSS/PAC Results

PDISTO Results

PSS
PAC



CIC

8-4

Comparing PDISTO and PAC(1)

PSIN Source Type = sine

amplitude=-10dBm

RF1=900 MHz
“moderate”
harms=2 or 3

RF1=900.2 MHz
“moderate”
harms=2 or 3

LO=1 GHz
“large”
harms=5

IF1=100 MHz
IF2=99.8 MHz
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amplitude=-30dBm
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Comparing PDISTO and PAC(2)

• The number of harmonics of the large signal does not
affect the simulation time, where the number of harmonics
on the moderate signals greatly affects simulation time.

• Always specify at least 1 harmonic on each signal in a
PDISTO analysis.

• PDISTO analysis does not take as long as a PSS analysis
with a small PSS Fundamental, but it is longer than a
PSS/PAC analysis.
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PDISTO Assumptions
• Unlike PSS, PDISTO does not required multiple inputs be

commensurate or coperiodic. However, they still must be periodic.

• For coperiodic, well separated signals, use PSS.

• For signals that are closely spaced or not coperiodic, use PDISTO.

• For circuits driven by 2 or more moderate signals or at unrelated
frequencies, use PDISTO.

• If only one periodic signal is large enough to create distortion,
choose PSS followed by PAC or PXF.
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Lab8 : Simulation with PDISTO

• Modify the parameter values of PORT1 as follows:

• In the Simulation window, select Analyses → Choose; turn
off the pss and pnoise analysis

50Resistance

frf +1MFrequency2
prfAmplitude2 (dBm)
prfAmplitude (dBm)
frfFrequency

sineSource type

ValueParameter
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Setting Up the PDISTO Simulation(1)
• In the Choosing Analyses form, select pdisto for the analysis. Use

the Clear/Add button to change the values in the Fundamental
tones list box as shown right.

• Remember to select gear2only button in
the Options form.

• Select Simulation-Options-Analog,
and set the Tolerance Options as
recommended.
If the signals
are truly large,
relax reltol to
1e-4.
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Setting Up the PDISTO Simulation(2)

• Remember to select the output terminals to be saved and plotted before the
simulation.

• Increase the power of the input RF signals from – 40 dBm to – 30 dBm.(P-
1dB for this circuit is – 22 dBm) In the PSS/PAC analysis, you used a PAC
tone that was at least 10 dB below
the 1 dB compression point to
prevent violating the small
signal assumptions associated
with the PAC analysis. This
restriction does not apply to
PDISTO.

• Select Netlist and Run button
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Plotting Simulation Results

• Use Direct Plot function to see the results. Follow the
prompts at the bottom of the form, and select instance
terminal (RL1) in the schematic

zoom in
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Simulation IP3 with PDISTO(1)
• The setup for this measurement is very similar to the one used

for the swept PSS simulation, except you will be using PDISTO
with two moderate tones and one large reference signal.

• Modify the parameter values of PORT1 as follows:
• Check and save.

50Resistance

frf +25MFrequency2
prfAmplitude2 (dBm)
prfAmplitude (dBm)
frfFrequency

sineSource type

ValueParameter
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Simulation IP3 with
PDISTO(2)

• In the PDISTO Analyses form, use
the Clear/Add button to change the
values in the Fundamental tones list
box. Set up the Sweep Range as
shown right.

• Remember to choose the gear2only
method and set the Tolerance
Options as recommended or relax
reltol to appropriate value. Click OK.

• Run the simulation.



CIC

8-13

Displaying the
IP3 Plot(1)

• Use Direct Plot function to see
the results. Set up the PDISTO
Results form as shown right.
Follow the prompts at the bottom
of the form, and select instance
terminal (RL1) in the schematic

LO: 2.3 G           RF: 2.4 G & 2.425G

1st order harmonics: 100M & 125M       

3rd order harmonics: 75M & 150M
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Displaying the IP3 Plot(2)

-16

-14.5 dBm
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9. Oscillator and Phase Noise Analysis

• SpectreRF-PSS analysis can be performed on
autonomous or nondriven circuits, such as oscillators.

• Oscillator analysis includes two phases:
– The initial transient phase:

The PSS monitors the potential difference between the two nodes
specified and the waveforms in the circuits, and this analysis develops
a better estimate of the oscillation period of the circuit.

– The shooting phase:
The circuit is simulated repeatedly while the length of the period and
the initial conditions are adjusted to achieve a periodic steady state
solution.
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Troubleshooting Oscillators
• Does not converge – increase tstab

• Improve the estimate of the period. Be especially carefully
that the period specified is not too short.

• Change the value of the method parameter from gear2only
to trap or traponly.

• Does not converge – increase maxperiods

• If the shooting iteration approaches convergence and fails,
increase the value of the steadyratio parameter, but never
set steadratio larger than 0.1.

• Change the value of the tolerance parameter.
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Oscillator PSS Algorithm

• tstart - Start time for transient analysis.(default is 0)

• Tonset – Time when the last stimulus waveform becomes periodic.

• PSSperiod – the guess period entered by the user.

• tstab – additional stabilization time entered by the user.

• maxstep = (Ttran / 50)(default).

• The algorithm then adds a further 4 periods of our guess frequency of
transient analysis in order to measure the oscillator frequency.

Tonset 2×PSSperoid tstab 4×PSSperoid PSS

Ttran Ttran_end

tstart
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Oscillator Algorithm and maxstep
• Default maxstep > period if Ttran > 50 oscillator periods. The

oscillator might not start correctly or a metastable state might be
found by the simulator.

• Use tighter convergence criteria or set maxstep < 1/(200×FreqOsc)

• In PSS shooting iterations stage, maxstep is the smallest of:
– maxstep manual entry
– PSSperiod/(maxharm×40)
– 1/(maxacfreq×5)
– PSS Beat Frequency/200

• Setting a high harmonic in the PSS analysis or setting maxacfreq
will only effect the maxstep of the PSS shooting iterations but
NOT the maxstep of the initial transient section.
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Lab9 : Tunable Oscillator – Transient Analysis
• Create a new

schematic
view.

• Use library
“analogLib”
& “tsmc18rf”
to draw the
scheme.

• Use a vpulse
source to
kick-start the
oscillator.

Vout2Vout1
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Set Up the Design Environment
• In the Design Environment form select Setup → Model

Libraries to set up the model library as show below.

• Select Variables → Copy From Cellview to set the variable
vctrl to be some value.
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Transient
Simulation set up

• Select Analyses → Choose to set
up the transient simulation as
right window.

• Set up the form and option form
as shown right:

• Push Netlist and Run button.
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Display the Transient Results

Transient Signal; then
select Vout1 node in
the schematic and press
ESC key to end the
selection. The Vout1
transient node voltage
appears in the
Waveform window.

• In the Analog Artist Simulation window, select Results → Direct Plot →
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Oscillator Notes
• When applying initial conditions to start an oscillator, first run

a transient analysis to get the voltages for a few nodes in the
circuit. To set the initial conditions for the next run, select
Simulation – Convergence Aids – Initial Condition.

• In the Transient Options form, set a value such as spectre.fc for
the writefinal parameter in the STATE FILE PARAMETERS
section. The spectre.fc file will have all of the final conditions
on the nodes in the circuit.

• Before running another transient or PSS analysis, set readns to
spectre.fc in the CONVERGENCE PARAMETERS section of
the Options form.
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spectre.fc file
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Use the DFT Function
• In the Waveform window, click the Add Subwindow icon, then a

subwindow with a label of 2 in the upper right corner is added.

• Click the Calculator, then the calculator appears.

• Click the vt button in the Calaulator and follow the prompt at the bottom of
the schematic window. Then select the Vout1 node in the schematic and
press Esc; click and hold Special Functions and select dft form from the
Special Function list.

• Fill in the form as follows: And
click OK.
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The Frequency Domain Results
• Finally, in the Calculator, click erplot
• Note the initial estimate of the

oscillation frequency is developed.

zoom in

2.33GHz



CIC

9-13

PSS/PNOISE Analysis(1)
• In the Choosing Analysis window, turn off the

transient analysis; select the pss analysis and set up the
form as right:

• An estimate of 2GHz was selected for Beat Frequency.
It’s recommended to estimate a lower frequency than
expected to help in the convergence.

• The value of tstab is set to 100n to inform the
simulator that the oscillation needs 100ns to stabilize to
a steady-state waveform.

• Remember to choose the gear2only method in the
options form.

• Click Apply.
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PSS/PNOISE Analysis(2)
• Next, click the pnoise button, and set up the PNOISE

analysis as right:

• The phase noise from 1 Hz to 10 MHz, relative to the
derived oscillation frequency, will be calculated.

• The Sidebands field is set to a Maximum sideband of
0. In this case, you are interested in the upconverted
1/f device noise to the oscillation frequency. To
account for higher harmonics of the oscillator that also
contribute noise, change this value.

• No Input Source is specified.

• Click OK.
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Run PSS & PNOISE Simulation
• Click the Run Simulation icon and use

Direct function to see the results.
• Compare the oscillation frequency with the

previous transient results.
• Click Plot icon, and the waveform window

appears.


